PPPoE client in IOS XE Denali 16.2.1

interface GigabitEthernet1
 ip address 10.9.8.1 255.255.0.0
 ip nat inside
 negotiation auto
! 
interface GigabitEthernet3
 no ip address
 negotiation auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
! 
interface Dialer1
 mtu 1492 
 ip address negotiated
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 ipv6 address autoconfig
 ipv6 enable
 ppp pap sent-username 43228 password c4d
!

ip route 0.0.0.0 0.0.0.0 Dialer1
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 10.9.0.0 0.0.255.255
!